non vorrei lavorare

ブログ名の通りです。javascript three.js mruby rust OCaml golang julialang blender

WebKitGTK+を試すも「libgcrypt 1.7.0 is required to enable Web Crypto API support.」

この記事は@kjunichiの2017年パーソナルアドベントカレンダーの21日目の記事です 。

WSLでWindows側にXサーバーをインストールしないでXクライアントを動かしているのだが、 SafariのTechnology PreviewのページでたまたまLinux向けのWebKitがDLできることを知って 試しているのだが、

cmake -DPORT=GTK -DCMAKE_BUILD_TYPE=RelWithDebInfo&&make -j `nproc`
-- The CMake build type is: RelWithDebInfo
-- Could NOT find Ruby (missing:  RUBY_INCLUDE_DIR RUBY_LIBRARY RUBY_CONFIG_INCLUDE_DIR) (found suitable version "2.3.0", minimum required is "1.9")
-- Performing Test CXX_COMPILER_SUPPORTS_-std=c++14
-- Performing Test CXX_COMPILER_SUPPORTS_-std=c++14 - Success
-- Checking for module 'gtk+-quartz-3.0'
--   No package 'gtk+-quartz-3.0' found
-- Found ICU header files in /usr/include/x86_64-linux-gnu
-- Found ICU libraries: /usr/lib/x86_64-linux-gnu/libicuuc.so
-- Found ICU internationaliation libraries: /usr/lib/x86_64-linux-gnu/libicui18n.so
-- Found ICU data libraries: /usr/lib/x86_64-linux-gnu/libicudata.so
CMake Error at Source/cmake/OptionsGTK.cmake:268 (message):
  libgcrypt 1.7.0 is required to enable Web Crypto API support.
Call Stack (most recent call first):
  Source/cmake/WebKitCommon.cmake:59 (include)
  CMakeLists.txt:159 (include)

文句言われたlibgcryptのバージョンをソースからビルドして入れたが、解消しない。 CMakefileを読み進めて解決できるのかなぁ

関連記事

3年前の記事

2年前の記事